Calliope 2017 - funktioniert nur mit "altem" Mini Editor


#1

Hallo, mein aktueller Calliope (Logo unten links) funktioniert ausschließlich mit dem Beta Editor unter https://miniedit-r03.calliope.cc/. Alle Programme aller anderen Editoren (neu oder alt) werden vermutlich nicht ausgeführt (Neustart Calliope, nichts passiert). Update mit FW kl26z_… hat nichts verbessert. Inhalt Details.txt:

DAPLink Firmware - see https://mbed.com/daplink

Unique ID: 12A0000043114e45004d90020000004c0000000097969901
HIC ID: 97969901
Auto Reset: 1
Automation allowed: 0
Daplink Mode: Interface
Interface Version: 0242
Bootloader Version: 0242
Git SHA: eab079b8a1326f0a3647e3df33cf5dda13994a1f
Local Mods: 1
USB Interfaces: MSD, CDC, HID
Bootloader CRC: 0x459c23c8
Interface CRC: 0x772b65c8

Was kann ich machen - so macht das wenig Spass, wir haben ohne die neuen Editoren kaum Möglichkeiten, interessante Programme zu schreiben. Dabei wollte ich meinen Jungs doch was beibringen. Vielleicht weiß jemand Rat!

Gruß,
Christian Rüster


#2

Hallo Christian,

heißt das, du kannst Programme mit dem alten Editor auf den Calliope aufspielen und dort ausführen und mit allen anderen Editoren nicht? Blinkt die gelbe LED am rechten Grove-Anschluss beim Aufspielen der HEX-Dateien, egal aus welchem Editor? Hat der Calliope auf der Rückseite eine angedeutete Bohrung? Die Detail.txt sieht bei mir auch so aus.

Toni


#3

Hallo Tino,

Danke für die Nachfrage! Das ist schon ziemlich so wie beschrieben.
Ein genaues Beispiel:

  • ein einfaches Programm Wenn “A gedrückt” dann "zeige Bild Glücklich"
    funktioniert wenn ich es auf der Webseite
    https://miniedit-r03.calliope.cc/ erzeuge. Ich habe es als
    calliope_mini(10).hex angehängt.
  • das gleiche Programm funktioniert nicht wenn ich es mit dem neuen
    Editor auf der Seite https://miniedit.calliope.cc/ erzeuge
    (miniProgram(4).hex). Calliope bootet neu - bei Drücken auf A kommt
    keine sichtbare Reaktion.
  • Alle anderen Editoren erzeugen auch keinerlei sichtbar lauffähige
    Programme. Neustart - dann nichts.
    Das mit der angedeuteten Bohrung auf der Rückseite sagt mir nichts -
    vermutlich habe ich keine. Habe auch mal ein Foto angehängt!

Ich hoffe mit den Infos kommt man weiter. Es kommt mir schon ziemlich
mysteriös vor.

Gruß,
Christian


#4

Hallo Christian,
leider habe ich jetzt erst deine Frage gesehen. Du nutzt den falschen Editor, bitte nimm die auf der Webseite (https://calliope.cc/los-geht-s/editor) angegebenen.
Du solltest damit Ergebnisse erzielen können. Die Editoren liefern eigentlich immer die identischen Daten (allerdings mit dem Unterschied der Unterstützung der Grove Konnektoren und des B-Buttons)… Warum nur der alte mini Edit gehen soll, kann ich nicht nachvollziehen. Kopiere doch einfach mal die Demo erneut auf den mini (https://github.com/calliope-mini/calliope-demo/releases/download/v2.0/calliope-demo-2.0-de.hex) und probiere es dann erneut.
Grüße
Jörn


#5

Hallo Joern,

super - Danke dieser Editor geht. Ist echt verwirrend mit den
verschiedenen Seiten - und warum die anderen Editoren nicht liefen.

Gruß,
Christian