Inkompatible Pakete


#1

Ich würde gerne das Neopixel-Paket mit dem Bluetooth-Midi-Paket gleichzeitig verwenden, allerdings bekomme ich eine Fehlermeldung die besagt, dass das jeweils andere Paket zuerst deinstalliert werden muss. Hat jemand eine Idee weshalb diese Pakete inkompatibel sind und wie man das Problem allenfalls umgehen könnte ?


#2

Ich kann es nicht sicher sagen, habe aber die Vermutung dass es schlicht ein Problem mit der Größe der Pakete ist. Das BT-Paket ist sehr voluminös und der Speicher des mini ziemlich begrenzt…


#3

Die Größe ist wohl hier nicht entscheidend. Eher sind gemeinsame Ressourcen wie Interrupts und Timer entscheident. Das Neopixel Paket benõtigt z.B. eine exakte Abfolge der Daten auf der Datenleitung. Wenn das nicht passiert wird Müll dargestellt. Schön wäre es, wenn man die Ausführung von Paketen anhalten und starten könnte, um diese gemeinsam zu verwenden.