Calliope mit Swift Playground geht nicht

Hallo,

mein Calliope funktioniert mit MakeCode übers iPad einwandfrei, inkl. Kopplung. Jetzt wollten wir gerne auf Swift Playground umsteigen und haben hierzu die Playgrounds App (neueste Version 3.1) sowie den neuesten Calliope Mini Playground innerhalb der Swift Playgrounds App (da steht „Swift 4.2.1“ drunter) geladen. Leider erscheint immer am Ende der Einführung eine Fehlermeldung: „Fehler beim Lesen der Quelltags Fehlerhaft verschachteltes Tag: editable-code“. Zu der Seite mit dem kleinen roten Button oben rechts, um die Verbindung zu starten, kommt man gar nicht. Man kann im Calliope Mini Playground nur die Einführungseiten anschauen, bei allen Seiten kommt immer nur diese Fehlermeldung und man kann sonst nichts machen. Der Calliope selbst ist im Pairing-Mode. Ich habe schon alles mögliche versucht: Neueste Calliope Firmware aufgespielt, Swift Playgrounds App gelöscht und neu installiert, Calliope Mini Playground gelöscht und neu geladen. Hat aber leider alles nichts gebracht. Habt Ihr eine Idee, was es sein könnte?

Vielen Dank und viele Grüsse,
Tom

Hallo,
ich habe genau das gleiche Problem. Hast du bereits eine Lösung gefunden?

Vielen Dank!

Leider nein. Ich habe Google nach der Fehlermeldung oder sonstigen Hinweisen abgesucht, aber nichts gefunden. Dann habe ich den Eintrag hier verfasst. Ich vermute, es liegt an der neuen Swift Version, ggf. muss der Calliope Playground dafür aktualisiert werden. Das müsste aber vermutlich der Ersteller machen. Ich hoffe, es meldet sich noch jemand vom Calliope Team.

Danke dir für die Antwort. Ich habe Calliope auch über Twitter angeschrieben.

Hallo!
Ich habe die Nachricht leider eben erst gelesen. Es gibt leider ein Problem mit der neuen Version von Swift Playgrounds.
Wir haben aber schon eine neue Version fertig, das Update sollte evtl. noch heute oder in den kommenden Tagen freigegeben werden. Dann funktioniert alles wieder.
Beste Grüße
Jörn

1 Like

Super, das hört sich gut an. Bitte idealerweise dann auch hier einen Beitrag veröffentlichen bzw. antworten, sobald das Update fertig ist. Vielen Dank!

Das Update ist jetzt freigegeben und sollte dementsprechend auch zu laden sein!
Beste Grüße
Jörn

Funktioniert, vielen Dank! Ich musste allerdings die Firmware neu installieren, sonst hat das Pairing nicht geklappt. Was mir allerdings aufgefallen ist: Die Farb-LED funktioniert nicht, sie geht nicht an und ändert entsprechend auch nicht die Farbe. Über die anderen Editoren funktioniert sie. Nochmals vielen Dank für den Fix!

Checke ich, sollte eigentlich funktionieren!

Beste Grüße
Jörn