Anfaenger und mp3 modul

Hallo ihr Lieben, gleich vorweg, ich bin blutiger Anfaenger. :innocent:
Wenn das am Ende alles zu schwierig für mich ist, gerne einfach sagen.

Ich arbeite im Haus der Jugend Langenhagen und versuche A) dort nach und nach das maker thema zu platzieren - wer Lust hat dort was anzubieten kann mich gerne anschreiben.
(kiju-langenhagen.de)

und B) selber mich einzuarbeiten.

Daher hab ich eine Sirene nachgebaut für ein ESCAPE SPIEL
https://medienundbildung.com/fileadmin/user_upload/CODE_BREAKERS_mobile_Spielanleitung_online.pdf
Dafür versuche ich nun das mp3 modul an der Calliope zum laufen zu bringen.

Ich habe mittlerweile zwei mp3 module


versucht - aber es kommt kein Ton heraus. Nun glaub ich vielleicht liegt es am Strom? Kann das sein? Vielleicht hat ja jemand Lust mir zu helfen. Lg Nico Filip

Hallo Nico,

das ist ein super Projekt. Haben die da auch das Modul eingebaut? Es kann durchaus sein, dass das 5V benötigt (was nicht verwunderlich wäre). Es gibt aber eins von Seeed, da hat @klmi (u.a. hier: MP3-Player: Batterieblock vs. USB-Powerbank (Brummen) - #5 von romtrim) Sachen mit gemacht. Ich habe das hier irgendwo liegen und könnte es auch mal testen. Das sollte problemlos funktionieren. Aus der Basis (WT2003S-20SS) haben wir mal ein anderes Projekt gebaut. Das läuft aber dann über A0 (I2C), also dem linken Konnektor am mini… Zu deinem habe ich praktisch keine Infos gefunden. Das heißt aber natürlich nichts. Wenn du zu dem Grove-Modul (Grove - MP3 v3.0 - Seeed Wiki) wechseln könntest, ist es bestimmt einfacher.

Übrigens ist das Haus der Jugend großartig. Ich komme zwar nicht aus Langenhagen, war aber häufiger bei Veranstaltungen dort! :slight_smile: Ein Freund von mir hatte dort damals Zivildienst gemacht…

Beste Grüße
Jörn

1 „Gefällt mir“

Das funktioniert nur wenn der Calliope über USB mit Strom versorgt wird. Wahrscheinlich wegen der Speicherkarte. Eventuell einen anderen Typ SD Karte probieren. Mit 4GB ging es gut, mit 16 GB nicht und mit 32GB ging es wieder. Wenn ein Titel gespielt wird, blinkt es auf dem Modul.

Die mp3-Dateien müssen natürlich auch richtig gespeichert sein.

Ich habe meine Projekte hier zur Verfügung gestellt:

(bis „Serial MP3 Player“ herunter scrollen)

Lutz

1 „Gefällt mir“

Hi und danke ihr Lieben, ja das hab ich schon gesehen - dachte das bekomm ich dann hin.
Ich versuche mal ne andere Karte aufzureiben.

Sind die Module denn geignet - hab irgendwo gelesen, dass das REV 1.2 modul wohl nicht kompatibel ist? stimmt das?

das find ich leider nirgends

Danke schon mal fürs feedback

Hallo Nico Filip!

Zwei mögliche Probleme fallen mir ein.

  1. RX und TX müssen gekreuzt sein, also RX vom mini an TX vom Modul und umgekehrt.
  2. Falsche Namensgebung der Dateien. Hinweise hierzu in meinem hackster-projekt Interaktive Plakate, Modelle und Dioramen mit Calliope Mini - Hackster.io

Und es stimmt, die Batterien müssen frisch sein und halten nicht lange durch. USB ist da die sicherere Sache.

Viel Erfolg!

Michael

1 „Gefällt mir“